Jump to content
Gopher's Minions

[SOLVED] Script latency issues

Recommended Posts

Hello everyone,

After months of modding my game I have reached the point where it seems scripts have begun to take their toll on my system.

After using the Convenient Horses inherent script latency test tool I got a result of ~400ms average latency, but it seems to spike quite often, with spikes ranging from 1100ms up to 5900ms on a good day.

The most annoying thing is a delay that occurs when switching gear using the SkyUI item groups on the favourites menu, which happens very often. This seems to somehow affect other actions and scripts as well.

I’ll give you an example to help understand the situation: I am using the Bandolier - Bags and Pouches mod to get extra carrying capacity and these items’ bonuses do not seem to take effect after a minute or so every time I start Skyrim afresh. This results in my character not being able to run until scripts are fully loaded and the extra carrying capacity effect is actually applied. This probably means that scripts just need some time to fully load at game start, which would be understandable, except it takes too much time to my mind.

This type of delays keep happening all over, at any time in game (during conversations or other scripted events, etc.) and, basically, results in me having to wait for a good minute until whatever’s happening resolves itself, IF it finally does so.

The funny thing is that I accidentally figured out that, every time this happens, popping up the favourites menu and hovering over the item groups seems to somehow jump-start the thing and it unfreezes. The exact same thing has happened to previous playthroughs of mine and I must say it is quite annoying and disruptive for the game experience.

Now, I am unsure whether this is caused by SkyUI alone or by a combination of mod scripts. My ‘core’ mods have not changed much throughout the playthroughs that have been affected by this. I am linking my mod load order from Nexus Mod Manager so you can get a basic idea of what’s running on my game. As you will see the list is pretty extensive, but I believe the core mods have remained unchanged and it’s those that are probably causing this trouble.

I also occasionally get some CTD’s at random times during play, but I do not know if that is related to the above.

So, my question is simple: how do I optimise my game without destroying my save? Is there a way of fixing this mess, getting rid of any excess scripts that are not being used, etc?

Thanks a lot in advance, your input will be much appreciated.

Link to post
Share on other sites

Tried to do some fixing on my own today.

First, I used TES5Edit to clean all essential game files, based on [uSER=4]@Gopher[/uSER]'s tutorial video. I also cleaned the Amazing Follower Tweaks mod using TES5edit's mod cleaning tutorial (basically the exact same process as above).

Loot did not show any errors and, since my game doesn't CTD on startup, I left my load order as it is.

Finally, I followed the instruction on this post and added the following lines in my Skyrim.ini file:












Results: The game seems to be running slightly faster and more smoothly now. I do not know if this is going to be enough for long-term play, though. I am currently in the middle of a planned playthrough, I still want to play Undeath and the Dragonborn DLC and I suspect that I may have to clean up my save files, as well.

So, I would really appreciate any further suggestions.

Thanks in advance.

Link to post
Share on other sites
  • 2 weeks later...

Well, after a lot of hours of research I decided there was nothing more I could do and just went with it...

Then, after a few days, I decided to migrate to Mod Organizer as a long-term solution to better manage my Skyrim mods for future playthroughs.

Finally, after a full day of tinkering and configuring the application, I managed to put together a playable load order. Apart from Mod Organizer, I used TES5edit and LOOT, I updated some mods and, once I loaded my save, I noticed that all the latency issues I used to have were gone! :)

I am not certain what was that fixed the issue, but, after this whole process, I ended up with a perfectly playable save, once more! It no longer feels like I'm playing an old and script-heavy playthrough, it feels like I just started a new, lag-free game! I have now even installed Face to face conversation which I had to previously unistall, as it caused even more issues. It now works like a charm!

This is awesome and, while this is slightly off-topic, I feel I have to thank [uSER=4]@Gopher[/uSER], as I wouldn't be able to set MO up without his great tutorial videos! Kudos to you, sir. gopherVaultStiv

Link to post
Share on other sites
  • 6 years later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Create New...